您好、欢迎来到现金彩票网!
当前位置:爱彩网app下载 > 工具提示 >

ARM-linux-gcc交叉编译工具提示arm-linux-gcc can not fd

发布时间:2019-04-25 11:33 来源:未知 编辑:admin

  以上提示你安装的交叉工具链的把版本信息,但是你编译内核时,系统会提示错误某些文件不能执行,于是就加上了sudo,试图通过sudo权限能编译通过,结构不行提示arm-linux-gcc can not find,....怎么啦?咋回事?????

  B: vi /etc/profile 命令,你会发现这个并不是上一大步修改的文件吗?是的就是你在用户权限下用sudo vi /etc/profile 修改并保存的东西,这里我们不用再次修改了。因为关键在下面的第3点

  总结:原因是编译文件我们需要超级权限Root,在用户权限下安装的交叉编译工具,超级权限编译文件时是找不到的,相当于只有你是一个军火供应商,你有很多枪,但不好意思,只有警察才有权限适用,普通用户你没得权限适用不了,怎么办呢?你得通过使用说明书告诉警察这些武器是怎样使用的。sudo -S 切换到ROOT权限 ,在root权限下 source /etc/profile,才能给root 注册有关的交叉工具信息

http://adcamp.net/gongjutishi/72.html
锟斤拷锟斤拷锟斤拷QQ微锟斤拷锟斤拷锟斤拷锟斤拷锟斤拷锟斤拷微锟斤拷
关于我们|联系我们|版权声明|网站地图|
Copyright © 2002-2019 现金彩票 版权所有